invis.net

Problems with 4.3.0.4

After updating to * 4.3.0.4 we are receiving hundreds of mails from our wp-cronjobs. Were there some classes changed?

Error thrown

Class 'org\lecklider\charles\wordpress\wp_fail2ban\Config' not found

Error thrown

Class 'org\lecklider\charles\wordpress\wp_fail2ban\Config' not found

Tags for 4.3.x.x are missing - could not add the right ones

The name of that particular class hasn’t, but lots of other things changed.

What are you running from cron and how are you calling it? I use it for boring stuff like scheduling posts without problems - are you doing something more esoteric?

Good point, thanks - I’ve changed the tag.

We are creating vbulletin threads as comments for our wordpress posts.

I havve to ask our coder how they are called.

For some things we don’t use Wordpress’ cron infrastructure because we need a bit more control. Therefore we call a PHP script from a Linux cron, like this:

cd /path/to/wp-content/themes/ourtheme/
/usr/bin/php7.0 -f cronjobs.php do=do_some_stuff

In cronjobs.php the first line is:

require_once(dirname(FILE) . ‘/…/…/…/wp-load.php’);

And this triggers the error. It worked with older versions of WP fail2ban.
For this cronjobs.php we actually do not need WP fail2ban. So, if we find a way to disable it for this specific call, the problem will be solved.

OK, I’ve worked out what’s going on - I’ll fix it in 4.3.0.5.

The problem is that you’re running a script from a directory containing a file called functions.php, and PHP is loading that one instead of the one in WPf2b.

As it’s a simple fix I’m hoping to have the release done later tonight.

Great!! That would be very cool.

Didn’t quite make last night, pushed it earlier today. Let me know if it fixes the problem.

No problem, you made my day with the changelog:

Fix esoteric edge-case where

:rofl:

I will test later and give you the feedbak

Ok, thread creation is working now again. :+1:

Thanks for the fast fixing.