Opting in to freemius


When I click “Allow & Continue” on the “you must opt into Freemius for the blocklist to work.” screen absolutely nothing happens. I’ve tried to opt in various ways but it seems no good.

Only thing I see in the server error log is:
[Wed Mar 29 22:10:35.389741 2023] [php:warn] [pid 3250] [client] PHP Warning: Undefined array key "id" in /var/www/html/wp-content/plugins/wp-fail2ban/vendor/freemius/wordpress-sdk/templates/connect/permission.php on line 30, referer: https://www.BLAH.com/wp-admin/admin.php?page=wp-fail2ban_addon_blocklist

I’ve tried uninstalling-reinstalling. Version 5.0.1, Ubuntu and Wordpress all at latest.

Any advice would be appreciated

Thanks for the report and the screenshot - I’ve just release v2.2.1 which should fix this.

1 Like

Is there anything I need to do to get that update or will it be along in the wordpress plugin updates area?


It should show up as a plugin with an update in the usual way.

A post was merged into an existing topic: Opt-in to Freemius fails in v2.2.1