Opt-in to Freemius fails in v2.2.1

  • WP fail2ban v5.2.1
  • WP fail2ban - Contact Form 8 v2.0.0
  • WP fail2ban Blocklist v2.2.1
  • fail2ban-client version v0.11.1
  • WordPress 6.4.2
  • PHP 8.3
  • nginx 1.18.0 (Ubuntu)

Using the free version. When trying to ‘Allow & Continue’ to opt into Freemius it does nothing and the page refreshes. There’s no errors logged outside this one:

PHP Warning:  Undefined array key "id" in /var/www/html/wp-content/plugins/wp-fail2ban/vendor/freemius/wordpress-sdk/templates/connect/permission.php on line 30, referer: https://mysite.ca/wp-admin/admin.php?page=wp-fail2ban_addon_blocklist

I’ve enabled Debugging in the wp-admin/admin.php?page-freemius sections and don’t see any errors logs there. The Freemius State for WP fail2ban is OFF though, everything else looks good. I’m running a self-hosted WP on a VPS. I’ve pinged the remote address for Freemius and I am able to successfully ping it.

I’ve confirmed that I’ve opted in via the Plugins > WP fail2ban > 'Opt In' and tried the Allow & Continue but with no success.

I’ve also tried this suggestion from another thread and it does nothing.