No result and no opt-in when trying to opt-in with WP fail2ban Blocklist

Hi there,

I would appreciate a little help here, if possivle. :slight_smile:

Today I installed the WP Fail2Ban plugin and everything has gone Ok. I have active jails, etc.

After that I also installed the WP fail2ban Blocklist plugin. The installation was fine, but I need to use that option to “opt-in”.

And here comes the problem: whenever I click on “Allow and Continue” the page reload and I come back to the same place, where I am asked to “Allow and Continue” again.

Any idea about what could be causing this, please?

Thanks in advance.

I want to say I ran into this as well. I think I ended up uninstalling the plug-in and re-installing it and then it showed as “activated.”

I am also experiencing this issue.

The “allow and continue” button flashes “activating” and returns back to “allow and continue”.

When doing a site health check this issue is detected -

The Secret Key is used to authenticate with the Blocklist Network Service (BNS).
You have not connected to Freemius. Blocklist will not work without connecting.
[Connect to Freemius]

The connect to freemius link goes back to the “Allow and continue” screen and can’t connect?

Should an account be created on freemius?

Any idea how to fix?

Thanks in advance

Well, not even removing the plugin and reinstalling it again solved the issue.

I will keep it uninstalled for now. :frowning:

If you go to the Plugins page, there should be an “Opt in” link by the main WP fail2ban plugin. Could you try that one please?

It does the same thing behind the scenes but gets there by a different route.

I just installed Blocklist plugin again.

But when I go to the WP Fail2ban plugin page inside my admin area (Welcome) there’s no opt in link. Just a “must opt in” message at the bottom right.

Not the WPf2b main page, the main WP Plugins page - the one that lists the installed plugins.

There I can see only links to deactivate plugin, author’s website and details. But even details does not contains a opt in link.

Sorry, I saw the option you’ve mentioned. But there there’s no option to opt in to Freemius.

OK, just to make sure there’s no confusion and we’re talking about the same thing:


Thank you very much for your answer.

So, if I click that option no Freemius opt in is displayed in the popup:

Ah, OK - that looks like you’ve already opted-in to Freemius; quite why it still says “Opt in” is another question…

Could you have a look at the Freemius debug page (/wp-admin/admin.php?page=freemius) and let me know which version of the library it’s using please? It’s possible that another plugin has updated to 2.5.4 already and there’s something that’s changed (I’m in the process of testing it for the next release).

This sounds like it’s having a problem connecting to Freemius.

As with @marcos.zy could you have a look at the Freemius debug page (/wp-admin/admin.php?page=freemius) and tell me the version number pleese?


Thanks for your support. :slight_smile:

So, that page displays a version 2.5.3 for SDK.

Below this information there’s a table where I can see an “OFF” state for the plugin WP fail2ban (regarding Freemius State).