invis.net

Custom logpath not working

I have a conf file in /etc/fail2ban/jail.d/ with the configuration below, where I tried to set a custom logpath, but for some reason everything is still getting logged to auth.log. The permissions, etc, are correct for the logfile. Anyone know why the logpath directive is not working/overriding the default?

[wordpress-hard]
enabled = true
filter = wordpress-hard
logpath = /var/log/wp.log
maxentry = 3
port = http,https
bantime = 86400

same thing for [wordpress-soft]…

Welcome!

The logpath line tells fail2ban where to find the log to read - it doesn’t control how the log is written.

To control where the events are written you’ll need to look at syslog.conf.

1 Like

Oh wow, apologies. Thank you so much! That was a dumb mistake.